
<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# " class="h-100">
<head>
<meta charset="utf-8" />
<script async src="/sites/default/files/google_analytics/gtag.js?quc8g6"></script>
<script>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments)};gtag("js", new Date());gtag("config", "UA-88969255-1", {"groups":"default","anonymize_ip":true});</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&amp;l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WXSNZ9C');
</script>
<style>/* @see https://github.com/aFarkas/lazysizes#broken-image-symbol */.js img.lazyload:not([src]) { visibility: hidden; }/* @see https://github.com/aFarkas/lazysizes#automatically-setting-the-sizes-attribute */.js img.lazyloaded[data-sizes=auto] { display: block; width: 100%; }</style>
<link rel="canonical" href="https://energydigital.com/company/mpower" />
<meta http-equiv="content-language" content="en" />
<meta name="description" content="MPower: Vision backed by experience..." />
<meta name="keywords" content="" />
<meta property="og:site_name" content="Energy Digital" />
<meta property="og:type" content="company_report" />
<meta property="og:url" content="https://energydigital.com/company/mpower" />
<meta property="og:title" content="MPower | Energy Digital" />
<meta property="og:description" content="MPower: Vision backed by experience..." />
<meta property="og:image" content="https://energydigital.com/sites/default/files/styles/ma/public/large_15d90e80_d795_0319_9e68_b4754965220b.jpeg?itok=84yv39VA" />
<meta property="og:image:url" content="https://energydigital.com/sites/default/files/styles/ma/public/large_15d90e80_d795_0319_9e68_b4754965220b.jpeg?itok=84yv39VA" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:url" content="https://energydigital.com/company/mpower" />
<meta name="twitter:image" content="https://energydigital.com/sites/default/files/styles/ma/public/large_15d90e80_d795_0319_9e68_b4754965220b.jpeg?itok=84yv39VA" />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="application/ld+json">{
    "@context": "https://schema.org",
    "@graph": [
        {
            "@type": "Article",
            "headline": "MPower",
            "name": "MPower",
            "description": "MPower: Vision backed by experience...",
            "image": {
                "@type": "ImageObject",
                "representativeOfPage": "True",
                "url": "https://energydigital.com/sites/default/files/styles/ma/public/large_15d90e80_d795_0319_9e68_b4754965220b.jpeg?itok=84yv39VA"
            }
        },
        {
            "@type": "Organization",
            "additionalType": "Organization",
            "@id": "103037",
            "name": "Energydigital",
            "url": "https://www.fintech.com/"
        }
    ]
}</script>
<link rel="shortcut icon" href="https://energydigital.com/sites/default/files/styles/ma/public/brand-images/android-chrome-512x512_9.png?itok=79riDdi8" type="image/vnd.microsoft.icon" />
<link rel="revision" href="https://energydigital.com/company/mpower" />
<script>window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};</script>
<title>MPower | Energy Digital</title>
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_vqNQb36VmPSIu8nhK1e3rgdiFFPRVLBwhsqfvtrTbWI.css" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_pXOCwbv1JI7s_3uTptJL8rZyKcFp5jETYKtRuG8yU2Y.css" />
<link rel="stylesheet" media="all" href="/themes/custom/bizclik_sites/dist/main.min.css?quc8g6" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_wpfhIIbcj5xjdHDed5COq0rPsZnJbZQR12hgQxYuDq4.css" />
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body class="path-node page-node-type-company-report    bg- d-flex flex-column h-100">
<div class="loader"></div>
<a href="#main-content" class="visually-hidden focusable skip-link">
Skip to main content
</a>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WXSNZ9C" height="0" width="0" style="display:none;visibility:hidden;"></iframe>
</noscript>
<div class="dialog-off-canvas-main-canvas d-flex flex-column h-100" data-off-canvas-main-canvas>
<div class="page-wrapper energy_digital">
<div class="custom-overlay"></div>
<div class="form-overlay"></div>
<header role="banner" class="header">
<div class="top-header">
<div class="top-header-left">
<div class="logo-region">
<div class="region region-logo-region">
<div id="block-sitebranding" class="site-branding block block-system block-system-branding-block">
<div class="site-brand">
<a href="/" title="Home" rel="home" class="site-logo">
<img src="https://energydigital.com/sites/default/files/styles/ma/public/brand-images/Energy-White.png?itok=rmbW7Iw2" alt="Home" />
</a>
</div>
</div>
</div>
</div>
<nav class="navbar navbar-region">
<div class="navbar-collapse" id="navbarSupportedContent">
<div class="region region-navbar">
<div id="block-brandswitcher" class="brand-switcher header-switcher block block-bizclik-brands block-brand-switcher-block">
<div class="dropdown show">
<a class="btn btn-secondary dropdown-toggle" href="https://energydigital.com/" role="button" id="dropdownBrand" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
Energy Digital
</a>
<div class="dropdown-menu" aria-labelledby="dropdownBrand">
<a class="dropdown-item" target="_blank" href="https://aimagazine.com/">AI Magazine</a>
<a class="dropdown-item" target="_blank" href="https://businesschief.asia/">Business Chief APAC</a>
<a class="dropdown-item" target="_blank" href="https://businesschief.eu/">Business Chief EMEA</a>
<a class="dropdown-item" target="_blank" href="https://businesschief.com/">Business Chief North America</a>
<a class="dropdown-item" target="_blank" href="https://constructionglobal.com/">Construction Global</a>
<a class="dropdown-item" target="_blank" href="https://cybermagazine.com/">Cyber Magazine</a>
<a class="dropdown-item" target="_blank" href="https://datacentremagazine.com/">Data Centre Magazine</a>
<a class="dropdown-item" target="_blank" href="https://fintechmagazine.com/">Fintech Magazine</a>
<a class="dropdown-item" target="_blank" href="https://fooddigital.com/">Food Digital</a>
<a class="dropdown-item" target="_blank" href="https://healthcareglobal.com/">Healthcare Global</a>
<a class="dropdown-item" target="_blank" href="https://insurtechdigital.com/">InsurTech Digital</a>
<a class="dropdown-item" target="_blank" href="https://manufacturingglobal.com/">Manufacturing Global</a>
<a class="dropdown-item" target="_blank" href="https://miningglobal.com/">Mining Global</a>
<a class="dropdown-item" target="_blank" href="https://mobile-magazine.com/">Mobile Magazine</a>
<a class="dropdown-item" target="_blank" href="https://procurementmag.com/">Procurement</a>
<a class="dropdown-item" target="_blank" href="https://supplychaindigital.com/">Supply Chain Digital</a>
<a class="dropdown-item" target="_blank" href="https://sustainabilitymag.com/">Sustainability Magazine</a>
<a class="dropdown-item" target="_blank" href="https://technologymagazine.com/">Technology</a>
</div>
</div>
</div>
<div id="block-regionswitcher" class="region-switcher header-switcher block block-bizclik-brands block-region-switcher-block">
<div class="dropdown show">
<a class="btn btn-secondary dropdown-toggle" href="/region/any" role="button" id="dropdownRegion" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
All
</a>
<div class="dropdown-menu" aria-labelledby="dropdownRegion">
<a class="dropdown-item" href="/region/asia">Asia</a>
<a class="dropdown-item" href="/region/eu">Europe</a>
<a class="dropdown-item" href="/region/uk">United Kingdom</a>
<a class="dropdown-item" href="/region/usa">Usa</a>
</div>
</div>
</div>
</div>
</div>
</nav>
</div>
<div class="top-header-right">
<div class="latest-issue-region">
<div class="region region-latest-issue-region">
<div class="views-element-container header-latest-issue block block-views block-views-blocklatest-issue-out-now-latest-issue" id="block-views-block-latest-issue-out-now-latest-issue">
<h2>Latest issue out now</h2>
<div><div class="latest-issue view view-latest-issue-out-now view-id-latest_issue_out_now view-display-id-latest_issue js-view-dom-id-187cf35d090a80db97cc6ccb865bd4e4e757766a2cc99ff21ad519226cb47723">
<div class="view-content">
<div class="views-row">
<div data-history-node-id="162395" role="article" about="https://energydigital.com/magazine/may-2021" title="Energy Digital Homepage | Energy Digital" class="node node--type-magazine node--view-mode-small-preview">
<div class="magazines-block">
<div class="magazines-cover">
<a class="magazine-link-button" href="/magazine-read/162395" rel="bookmark">
<div class="field field--name-field-magazine-cover field--type-entity-reference field--label-hidden field__item"><article class="media media--type-image media--view-mode-_-10-crop">
<div class="field field--name-field-media-image field--type-image field--label-hidden field__item"> <img width="300" height="424" alt="" loading="lazy" class="lazyload image-style-_-10-crop" data-src="/sites/default/files/styles/7_10_crop/public/image/01-Enery-Cover-May2021_0.jpg?itok=pwtm1rKd" typeof="foaf:Image" />
</div>
</article>
</div>
</a>
</div>
<div class="magazine-link">
<a class="magazine-link-button" href="/magazine-read/162395" rel="bookmark">
Read now
</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="views-exposed-form header-search block block-views block-views-exposed-filter-blocksearch-page-1" data-drupal-selector="views-exposed-form-search-page-1" id="block-search">
<h2>Search results</h2>
<form action="/search" method="get" id="views-exposed-form-search-page-1" accept-charset="UTF-8">
<div class="form--inline clearfix">
<div class="js-form-item form-item js-form-type-textfield form-type-textfield js-form-item-query form-item-query form-no-label">

<input placeholder="Search for content" data-drupal-selector="edit-query" type="text" id="edit-query" name="query" value="" size="30" maxlength="128" class="form-text form-control" />
</div>
<div data-drupal-selector="edit-actions" class="form-actions js-form-wrapper form-wrapper" id="edit-actions--3">
<input data-drupal-selector="edit-submit-search" type="submit" id="edit-submit-search" value="Apply" class="button js-form-submit form-submit btn btn-primary" />
</div>
</div>
</form>
</div>
</div>
</div>
</div>
</div>
<div class="bottom-header">
<div class="burger-btn">Open/Close</div>
<div class="bottom-header-region">
<div class="navigation-region">
<div class="region region-navigation-region">
<nav role="navigation" aria-labelledby="block-sitemenu-menu" id="block-sitemenu" class="main-menu block block-menu navigation menu--site-menu">
<h5 class="visually-hidden" id="block-sitemenu-menu">Site menu</h5>
<ul class="menu">
<li class="menu-item">
<a href="/interviews" data-drupal-link-system-path="interviews">Interviews</a>
</li>
<li class="menu-item menu-item--expanded">
<span> Categories </span>
<ul class="menu">
<li position="1" class="menu-item">
<a href="https://energydigital.com/topics/renewable-energy" data-drupal-link-system-path="taxonomy/term/65024">Renewable Energy</a>
</li>
<li position="2" class="menu-item">
<a href="https://energydigital.com/topics/smart-energy" data-drupal-link-system-path="taxonomy/term/65026">Smart Energy</a>
</li>
<li position="3" class="menu-item">
<a href="https://energydigital.com/topics/sustainability-3" data-drupal-link-system-path="taxonomy/term/65023">Sustainability</a>
</li>
<li position="4" class="menu-item">
<a href="https://energydigital.com/topics/utilities" data-drupal-link-system-path="taxonomy/term/65025">Utilities</a>
</li>
<li position="5" class="menu-item">
<a href="https://energydigital.com/topics/oil-and-gas" data-drupal-link-system-path="taxonomy/term/65022">Oil &amp; Gas</a>
</li>
<li position="6" class="menu-item">
<a href="https://energydigital.com/topics/technology-and-ai" data-drupal-link-system-path="taxonomy/term/65028">Technology &amp; AI</a>
</li>
</ul>
<div class="open-sub-menu">
<svg width="12" height="8" viewBox="0 0 12 8" fill="none" xmlns="http://www.w3.org/2000/svg">
<path d="M1.41 0.589844L6 5.16984L10.59 0.589844L12 1.99984L6 7.99984L0 1.99984L1.41 0.589844Z" fill="white" />
</svg>
</div>
</li>
<li class="menu-item">
<a href="/company_listings" data-drupal-link-system-path="company_listings">Companies</a>
</li>
<li class="menu-item">
<a href="/top_10" data-drupal-link-system-path="top_10">Lists</a>
</li>
<li class="menu-item">
<a href="/videos" data-drupal-link-system-path="videos">Videos</a>
</li>
<li class="menu-item">
<a href="/events" data-drupal-link-system-path="events">Events</a>
</li>
<li class="menu-item menu-item--expanded">
<span> Magazine </span>
<ul class="menu">
<li class="menu-item">
<a href="/magazine" data-drupal-link-system-path="magazine">Current Magazine</a>
</li>
<li class="menu-item">
<a href="/backIssues" data-drupal-link-system-path="backIssues">Back Issues</a>
</li>
</ul>
 <div class="open-sub-menu">
<svg width="12" height="8" viewBox="0 0 12 8" fill="none" xmlns="http://www.w3.org/2000/svg">
<path d="M1.41 0.589844L6 5.16984L10.59 0.589844L12 1.99984L6 7.99984L0 1.99984L1.41 0.589844Z" fill="white" />
</svg>
</div>
</li>
</ul>
</nav>
</div>
</div>
<div class="socials-region">
<div class="region region-socials-region">
<nav role="navigation" aria-labelledby="block-social-menu" id="block-social" class="header-socials socials-block block block-menu navigation menu--social">
<h5 class="visually-hidden" id="block-social-menu">Social</h5>
<ul class="menu">
<li class="menu-item">
<a href="https://www.linkedin.com/company/energy-digital-magazine" target="_blank" rel="noopener">LinkedIN</a>
</li>
<li class="menu-item">
<a href="https://twitter.com/Energy_Digital_" target="_blank" rel="noopener">Twitter</a>
</li>
<li class="menu-item">
<a href="https://www.facebook.com/energydigitalmag/" target="_blank" rel="noopener">Facebook</a>
</li>
<li class="menu-item">
<a href="https://www.instagram.com/energydigitalmag/" target="_blank" rel="noopener">Instagram</a>
</li>
<li class="menu-item">
<a href="https://www.youtube.com/channel/UCs4CepFq0mjqtede4rx0xdA" target="_blank" rel="noopener">Youtube</a>
</li>
<li class="menu-item">
<a href="https://medium.com/energy-digital" target="_blank" rel="noopener">Meduim</a>
</li>
</ul>
</nav>
</div>
</div>
</div>
</div>
</header>
<main role="main" class="main-content">
<a id="main-content" tabindex="-1"></a>
<div class="region region-content">
<div data-drupal-messages-fallback class="hidden"></div>
<div id="block-mainpagecontent" class="block block-system block-system-main-block">
<div data-history-node-id="3827" role="article" about="https://energydigital.com/company/mpower" title="MPower | Energy Digital" description="MPower: Vision backed by experience..." class="node node--type-company-report node--view-mode-full">
<div class="node__content">
<div class="layout layout--onecol" id="ad-banner">
<div class="layout__region layout__region--content">
<div class="block block-bizclik-site block-customgamwblock">
<div id="gamw_69331ee1-3028-4f25-89e7-683c478f1224" data-uuid="69331ee1-3028-4f25-89e7-683c478f1224" data-ad-unit="ergcompany_970x250"></div>
</div>
</div>
</div>
<div class="layout layout--onecol" id="onecol-article-details">
<div class="layout__region layout__region--content">
<div class="block block-layout-builder block-field-blocknodecompany-reportcreated">
<span class="field field--name-created field--type-created field--label-hidden">3 June 2020</span>
</div>
<div class="block block-layout-builder block-field-blocknodecompany-reporttitle">
<span class="field field--name-title field--type-string field--label-hidden"> <h1>MPower</h1>
</span>
</div>
<div class="block block-layout-builder block-field-blocknodecompany-reportfield-author-name">
<div class="field field--name-field-author-name field--type-string field--label-hidden field__item">
Admin
</div>
</div>
<div class="block block-layout-builder block-extra-field-blocknodecompany-reportreading-time">
8 min
</div>
</div>
</div>
<div class="layout layout--onecol" id="onecol-article-image">
<div class="layout__region layout__region--content">
<div class="block block-layout-builder block-field-blocknodecompany-reportfield-media-image">
<div class="field field--name-field-media-image field--type-entity-reference field--label-hidden field__item"><article class="media media--type-image media--view-mode-_-3-crop">
<div class="field field--name-field-media-image field--type-image field--label-hidden field__item"> <img width="620" height="349" alt="ALT" title="CAPTION" loading="lazy" class="lazyload image-style-_-3-crop" data-src="/sites/default/files/styles/8_3_crop/public/large_15d90e80_d795_0319_9e68_b4754965220b.jpeg?itok=tIB45n8i" typeof="foaf:Image" />
</div>
</article>
</div>
</div>
</div>
</div>
<div class="layout layout--onecol" id="onecol-company-profile">
<div class="layout__region layout__region--content">
<div class="block block-layout-builder block-field-blocknodecompany-reportfield-company">
<div class="field field--name-field-company field--type-entity-reference field--label-above">
<div class="field__label">Company:</div>
<div class="field__item">
<div data-history-node-id="103037" role="article" about="https://energydigital.com/company/energydigital" title="Energydigital | Energy Digital" class="node node--type-company-profile node--view-mode-company-profile">
<div class="company-profile-block">
<div class="group-wrapper">
<div class="company-logo">
</div>
<div class="label">
<span class="field field--name-title field--type-string field--label-hidden"> Energydigital
</span>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="block block-layout-builder block-field-blocknodecompany-reportfield-brochure-cover">
<a href="/brochure/3827/read">
<div class="field field--name-field-brochure-cover field--type-entity-reference field--label-above">
<div class="field__label">Brochure cover:</div>
<div class="field__item"> <img src="/sites/default/files/styles/7_10_crop/public/brochure_572b9492e06914.19203927.jpeg?itok=xL0DVO4N" width="175" height="237" alt="ALT" typeof="foaf:Image" class="image-style-_-10-crop" />
</div>
</div>
</a>
</div>
</div>
</div>
<div class="layout layout--twocol-section layout--twocol-section--75-25" id="twocol-section-desktop-sidebar">
<div class="layout__region layout__region--first">
<div class="block block-layout-builder block-field-blocknodecompany-reportfield-stand-first">
<div class="field field--name-field-stand-first field--type-string field--label-hidden field__item">MPower: Vision backed by experience...</div>
</div>
<div class="block block-layout-builder block-extra-field-blocknodecompany-reportbody-part-first">
<div class="block-field-blocknodecompany-reportfield-body-copy">
<div class="field__item clearfix text-formatted">
<p>Having dominated the distributed power generation and emergency power markets for many years, MPower is now building Australia’s renewable future.</p>
<p>The expertise and alliances developed over many years have positioned MPower well to tackle emerging markets within the renewable energy sector.</p>
<p><strong>In a nut shell</strong></p>
<p>MPower has grown from small but diversified beginnings to become a multi-faceted group with various businesses within different niches of the power industry.</p>
<p>“If you look at everything we do, everything is about distributed power,” said MPower Managing Director Anthony Csillag. “We take a lot of pride in where we come from, and it’s exciting to see the scope of projects we’ve been able to lead, with a very interesting and bright future ahead.”</p>
<p>MPower specialises in three distinct segments; solar power, energy storage, and sophisticated power systems for the oil and gas and mining industries.</p>
</div>
</div>
</div>
</div>
<div class="layout__region layout__region--second">
<div class="block block-layout-builder block-field-blocknodecompany-reportfield-company">
<h2>Company:</h2>
 <div class="field field--name-field-company field--type-entity-reference field--label-hidden field__item">
<div data-history-node-id="103037" role="article" about="https://energydigital.com/company/energydigital" title="Energydigital | Energy Digital" class="node node--type-company-profile node--view-mode-company-report-executive-side-bar">
<div class="node-title">
<h2>
<a href="https://energydigital.com/company/energydigital" rel="bookmark"><span class="field field--name-title field--type-string field--label-hidden"> Energydigital
</span>
</a>
</h2>
</div>
<div class="node__content">
</div>
</div>
</div>
</div>
<div class="block block-layout-builder block-field-blocknodecompany-reportfield-company">
<div class="field field--name-field-company field--type-entity-reference field--label-above">
<div class="field__label">Company:</div>
<div class="field__item">
<div data-history-node-id="103037" role="article" about="https://energydigital.com/company/energydigital" title="Energydigital | Energy Digital" class="node node--type-company-profile node--view-mode-company-report-side-bar">
<div class="node-title">
<h2>
<div class="title">
<span class="field field--name-title field--type-string field--label-hidden"> Energydigital
</span>
</div>
</h2>
</div>
<div class="node__content">
<div class="field field--name-field-logo field--type-entity-reference field--label-above">
<div class="field__label">Logo:</div>
<div class="field__item"> <img width="775" height="174" alt="ALT" loading="lazy" class="lazyload image-style-_-1-crop" data-src="/sites/default/files/styles/1_1_crop/public/4x6y771xka9vjuu4-.jpeg?itok=1PAXT1Ou" typeof="foaf:Image" />
</div>
</div>
<fieldset class="company-social js-form-item form-item js-form-wrapper form-wrapper" id="company-social">
<legend>
<span class="fieldset-legend">Company Social</span>
</legend>
<div class="fieldset-wrapper">
<a class="field__item field-website" href="https://www.fintech.com/">https://www.fintech.com/</a>
<a class="field__item" href="general@bizclikmedia.com"><span class="__cf_email__" data-cfemail="d5b2b0bbb0a7b4b995b7bcafb6b9bcbeb8b0b1bcb4fbb6bab8">[email&#160;protected]</span></a>
</div>
</fieldset>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="layout layout--onecol" id="onecol-section">
<div class="layout__region layout__region--content">
</div>
</div>
<div class="layout layout--onecol" id="onecol-section-other-companies">
<div class="layout__region layout__region--content">
<div class="views-element-container block block-views block-views-blockour-partners-our-partners our-partners-block partners-block grid-items four-items">
<h2>Our partners</h2>
<div class="views-element-container"><div class="partners our-partners view view-our-partners view-id-our_partners view-display-id-our_partners js-view-dom-id-a0c6290df90a560bf2860d2e9529fb83c6cc38e8e80bba9623576f7e56f52f1c">
<div class="view-content">
<div class="views-row"><div class="views-field views-field-rendered-entity"><span class="field-content">
<div data-history-node-id="165388" role="article" about="https://energydigital.com/partners/buttonface-0" title="ButtonFace | Energy Digital" class="node node--type-partners node--view-mode-teaser partners-node">
<div class="partners-block">
<div class="simple-partners-link">
<div class="node-title">
<h2>
<a href="http://mailto:art.purdie@buttonface.com.au"><span class="field field--name-title field--type-string field--label-hidden"> ButtonFace
</span>
</a>
</h2>
</div>
<div class="view-profile">
<a href="http://mailto:art.purdie@buttonface.com.au">View profile</a>
</div>
</div>
</div>
</div>
</span></div></div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="layout layout--twocol-section layout--twocol-section--75-25" id="twocol-section-desktop-sidebar">
<div class="layout__region layout__region--first">
<div class="block block-layout-builder block-extra-field-blocknodecompany-reportbody-part-second">
<div class="block-field-blocknodecompany-reportfield-body-copy">
<div class="field__item clearfix text-formatted">
<p><strong><em>Solar Power</em></strong></p>
<p>MPower builds solar farms from small remotes communities through to MW scale projects.</p>
<p>MPower’s vertical integration of the solar industry includes project development, engineering, procurement and construction (EPC) through to operations and maintenance for the life of the power-generating asset. Its scale of vertical integration has proven beneficial to many of its clients. Having completed a 1.7MW solar farm for Rio Tinto, MPower is nearing completion of a 5MW solar farm for First Solar in Samoa.</p>
<p><strong><em>Energy Storage</em></strong></p>
<p>MPower has led the energy storage revolution in Australia.</p>
<p>Its defining moment was solving the problems associated with maximizing the amount of solar power that could be integrated into remote aboriginal communities to reduce fossil fuel consumption. MPower’s solution was to support the solar power with stored energy through periods of cloud cover. The solar power became more stable and predictable facilitating larger amounts of solar power as an overall percentage of the off grid power plant.</p>
<p>Utilising this patented remote community technology, MPower solved problems in the residential energy market segment with its residential energy storage units (RES); the results of which have now been published by SP Ausnet. By storing energy generated from solar panels MPower can essentially time shift when solar power is used, even at night.</p>
<p>MPower recently completed and commissioned a large scale Lithium Ion energy storage system for the University of Queensland Gatton Campus. The universities research will essentially stress test the advances in Lithium Ion battery technology in preparation for the full scale commercialisation of large scale energy storage.</p>
<p><strong><em>Power systems </em></strong></p>
<p>MPower’s founding core capability of distributed power and emergency power in the commercial sector has enabled it to tackle the more critical and technically advanced oil &amp; gas and mining markets. Oil &amp; Gas operations emergency power systems could best be defined under a famous NASA quote “failure is not an option.” In recent years MPower has provided emergency power packaged solutions to the likes of Woodside for its NR2 Project, Chevron for its Barrow Island Project and to INPEX for its current Ichthys projects.</p>
<p>To understand how and why MPower is in the market segments it is today it’s important to understand the beginnings where its ASX listed parent TAG made strategic synergistic acquisitions.</p>
<p>One of the strategic acquisitions was Westpower Rectifiers which specialized in Direct Current (DC) applications, the acquisition to supplement its own battery distribution business. The use of DC was in decline due to the evolution of Alternating Current (AC) inverter technology, primarily used in variable speed control and UPS Power systems. With this decline DC applications were predominantly DC traction for rail, battery chargers and high current rectifiers used in water purification and electrowinning metal recovery applications. The DC expertise in the market declined, MPower continued in these and other unique DC markets growing its expertise</p>
<p>Solar power Photo Voltaic (PV) technology produces DC power, MPower was thus well positioned to meet the needs of the PV market and develop advanced technologies. These technologies included its patented grid stabilisation system (GSS) introduced earlier. The GSS is being used in remote communities to maximize the amount of PV embedded in local off grid power systems by compensating for power dips associated with cloud cover. This same technology was used to develop its residential energy storage (RES) unit being successfully trialed in the SP Ausnet network.</p>
<p>Advancements and developments continue such as its current project for the Karratha Airport on grid solar farm. MPower is providing a solution for the smooth ramp down of the solar farm power onto the Horizon power grid to prevent shock load drop off associated with intermittent cloud cover. The enhancement being engaged here is the integration of cloud predicting technology that will enable MPower to start ramping down solar power before any cloud arrives under a normal unsupported by power ramp down, minimizing the requirement for stored energy support. The net result a more cost effective solution by minimizing the battery support required.</p>
<p><strong>Leader in renewables</strong></p>
<p>What makes MPower different to other companies is how it combines new and old technologies with a skilled and experienced workforce to create products and power systems that go the distance. Add state-of-the-art engineering and project management facilities, and MPower is equipped to deliver on all manner of power related projects, stamped with a degree of sophistication that is unparalleled in the region.</p>
<p>“The pioneering spirit motivates our team. Anyone that works for us is not bored — nothing is mundane,” said Csillag.</p>
<p>This pioneering spirit can be seen in multiple projects headed up by MPower. The Chevron Gorgon project for MPower involved supplying a 32MW power station that was originally meant to be temporary but is still operating today.</p>
<p>“Given the challenge of limited space for the power plant, we also had to build it so it could operate continuously in emergency conditions, even in a cyclone,” said Csillag.</p>
<p>“We designed and built one of the highest density diesel power systems for that particular project. It was designed and structurally built to withstand and operate in Category 5 cyclones.”</p>
<p>Another example of MPower’s ever improving technology of renewable energy includes a 200 KW solar farm in the Kimberley region in Western Australia. Contracted to design and install the solar farm for the Aboriginal community of Yungngora, MPower delivered on all its promises. The community now receives roughly 25 per cent of its power from solar.</p>
<p>“Completing the Yungngora project leaves us with a sense of satisfaction, not only for helping remote communities become less reliant on fossil fuels, but also having an Australian-based MPower engineering team continue to progress this important technology,” Csillag said.</p>
<p><strong>Culture of empowerment </strong></p>
<p>Much of MPower’s success can be attributed to the learning culture it strives to create. As such, MPower has affiliations with all major universities, and continually sources and support talent from these institutions. MPower also supports a trade’s based workforce and apprentice scheme with continued training programs that have seen these young recruits progress through the organisation.</p>
<p>“We empower our young people early on and tend to have high employee retention rates, which help to attract a lot of applicants through word of mouth,” said Csillag. “We’re proud of our employees and it’s good to see their careers and ambitions being fulfilled.”</p>
<p>On the other end of the spectrum, MPower has assembled an army of talented veteran employees, most of which have been with the company for 10 years or more.</p>
<p>“We tailor programs around new and present employees, with everything from electrical to mechanical programs,” Csillag said. “Our workforce is very ambitious and we want to watch them grow.”<br />
<strong>On the horizon</strong></p>
<p>What’s next for MPower? MPower is working on energy storage applications from residential energy storage to utility scale storage systems.</p>
<p>“With the potential proliferation of the electric car, power networks could see peaks in power consumption that may not be accommodated. These peaks occurring when people arrive home from work docking and recharging their vehicles. To test the network’s capability to accommodate for this surge, we installed residential energy storage (RES) units with three kilowatts of solar on 10 different residential homes, and designed the system so it could be controlled and interrogated remotely from a central location,” said Csillag.</p>
<p>The test revealed that MPower could limit the residential demand by charging the batteries during the day with solar. Then, when the power limit of the residence was exceeded, it would be taken from the RES unit, instead of the grid.</p>
<p>“We’ve gone through different stages with trials and modifications. Conceptually all remote energy storage sites could be mapped and managed from a central location  to see how much storage each resident has and or needs, not just the 10 sites trialed but whole communities,” said Csillag.</p>
<p>According to Csillag, many of the power network’s small power lines — known as SWER lines — have never been upgraded. While communities have grown significantly in size so has the demand for power. The average power demand is generally accommodated however not peak power; another application for MPower’s RES unit known as peak power lopping, a natural extension of the developments to date.</p>
<p>“Moving forward, we’re continually looking at all potential usage of energy storage in the renewable energy sector and other markets,” said Csillag. “And we’re not just looking — we’re trialing new applications and putting ideas into motion.”</p>
<p>“We expect to make announcements later this year of the successful integration of a seamless off grid project where the plant can switch between diesel engine generated power to 100% solar power maintaining protection systems, an Australian and potentially world first application”</p>
</div>
</div>
</div>
</div>
<div class="layout__region layout__region--second">
<div class="block block-bizclik-site block-customgamwblock">
<div id="gamw_c8e09152-881b-4d17-9997-5ccd850a5688" data-uuid="c8e09152-881b-4d17-9997-5ccd850a5688" data-ad-unit="ergcompany_300x600"></div>
</div>
<div class="block block-bizclik-site block-customgamwblock">
<div id="gamw_372194e9-7967-42c9-8a86-a2f0c7514436" data-uuid="372194e9-7967-42c9-8a86-a2f0c7514436" data-ad-unit="ergcompany_300x250"></div>
</div>
</div>
</div>
<div class="layout layout--onecol" id="onecol-section-body">
<div class="layout__region layout__region--content">
</div>
</div>
<div class="layout layout--onecol" id="media-list">
<div class="layout__region layout__region--content">
</div>
</div>
<div class="layout layout--onecol" id="onecol-section-mobile-sidebar">
<div class="layout__region layout__region--content">
<div class="block block-layout-builder block-field-blocknodecompany-reportfield-company">
<h2>Company:</h2>
<div class="field field--name-field-company field--type-entity-reference field--label-hidden field__item">
<div data-history-node-id="103037" role="article" about="https://energydigital.com/company/energydigital" title="Energydigital | Energy Digital" class="node node--type-company-profile node--view-mode-company-report-executive-side-bar">
<div class="node-title">
<h2>
<a href="https://energydigital.com/company/energydigital" rel="bookmark"><span class="field field--name-title field--type-string field--label-hidden"> Energydigital
</span>
</a>
</h2>
</div>
<div class="node__content">
</div>
</div>
</div>
</div>
<div class="block block-layout-builder block-field-blocknodecompany-reportfield-company">
<div class="field field--name-field-company field--type-entity-reference field--label-above">
<div class="field__label">Company:</div>
<div class="field__item">
<div data-history-node-id="103037" role="article" about="https://energydigital.com/company/energydigital" title="Energydigital | Energy Digital" class="node node--type-company-profile node--view-mode-company-report-side-bar">
<div class="node-title">
<h2>
<div class="title">
<span class="field field--name-title field--type-string field--label-hidden"> Energydigital
</span>
</div>
</h2>
</div>
<div class="node__content">
<div class="field field--name-field-logo field--type-entity-reference field--label-above">
<div class="field__label">Logo:</div>
<div class="field__item"> <img width="775" height="174" alt="ALT" loading="lazy" class="lazyload image-style-_-1-crop" data-src="/sites/default/files/styles/1_1_crop/public/4x6y771xka9vjuu4-.jpeg?itok=1PAXT1Ou" typeof="foaf:Image" />
</div>
</div>
<fieldset class="company-social js-form-item form-item js-form-wrapper form-wrapper" id="company-social">
<legend>
<span class="fieldset-legend">Company Social</span>
</legend>
<div class="fieldset-wrapper">
<a class="field__item field-website" href="https://www.fintech.com/">https://www.fintech.com/</a>
<a class="field__item" href="general@bizclikmedia.com"><span class="__cf_email__" data-cfemail="f493919a91869598b4969d8e97989d9f9991909d95da979b99">[email&#160;protected]</span></a>
</div>
</fieldset>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="layout layout--onecol" id="onecol-section-social-share">
<div class="layout__region layout__region--content">
<div class="block block-addtoany block-addtoany-block">
<h2>Share Article</h2>
<span class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://energydigital.com/company/mpower" data-a2a-title="MPower"><a class="a2a_button_linkedin"></a><a class="a2a_button_twitter"></a><a class="a2a_button_facebook"></a></span>
</div>
</div>
</div>
<div class="layout layout--onecol" id="onecol-section-other-companies">
<div class="layout__region layout__region--content">
<div class="views-element-container block block-views block-views-blockother-companies-reports-other-companies-reports other-companies-block companies-block grid-items four-items">
<h2>Other companies</h2>
<div class="views-element-container"><div class="view view-other-companies-reports view-id-other_companies_reports view-display-id-other_companies_reports js-view-dom-id-33c26dfba813fc37d72fee829aafe9b763ab32f9ef44c4c3df598e57e8c2145c">
<div class="view-content">
<div class="views-row">
<div data-history-node-id="163540" role="article" about="https://energydigital.com/company/edzcom-solutions-driven-edge-connectivity-0" title="Edzcom: Solutions driven by edge connectivity | Energy Digital" description="Seamless connectivity is the cornerstone to driving digitalisation and building smart industries of the future, says Mikko Uusitalo CEO of Edzcom" class="node node--type-company-report node--view-mode-other-companies-reports">
<div class="company-report-block">
<a class="company-report-link" href="https://energydigital.com/company/edzcom-solutions-driven-edge-connectivity-0" rel="bookmark">
<div class="main-image">
<div class="field field--name-field-brochure-cover field--type-entity-reference field--label-hidden field__item"> <img width="300" height="424" loading="lazy" class="lazyload image-style-_-10-crop" data-src="/sites/default/files/styles/7_10_crop/public/image/COVER-Edzcom-May2021.jpg?itok=ds2aNLsD" typeof="foaf:Image" />
</div>
</div>
</a>
<div class="group-wrapper">
<div class="company">
<span class="field field--name-title field--type-string field--label-hidden"> Edzcom: Solutions driven by edge connectivity
</span>
</div>
</div>
</div>
</div>
</div>
<div class="views-row">
<div data-history-node-id="161493" role="article" about="https://energydigital.com/company/siemens-safe-mobility-solutions-smart-cities" title="Siemens: safe mobility solutions for smart cities | Energy Digital" description="How Siemens is developing a digital twin vehicle model for smart cities that will enable a safe and accessible future for autonomous transport..." class="node node--type-company-report node--view-mode-other-companies-reports">
<div class="company-report-block">
<a class="company-report-link" href="https://energydigital.com/company/siemens-safe-mobility-solutions-smart-cities" rel="bookmark">
<div class="main-image">
<div class="field field--name-field-brochure-cover field--type-entity-reference field--label-hidden field__item"> <img width="300" height="425" alt="Siemens: safe mobility solutions for smart cities" loading="lazy" class="lazyload image-style-_-10-crop" data-src="/sites/default/files/styles/7_10_crop/public/eewk32lknfrn0av130420213131.jpeg?itok=Ld0AXZFI" typeof="foaf:Image" />
</div>
</div>
</a>
<div class="group-wrapper">
<div class="company">
<div class="field field--name-field-company field--type-entity-reference field--label-hidden field__item">
<div data-history-node-id="153184" role="article" about="https://energydigital.com/company/siemens-5" title="Siemens | Energy Digital" class="node node--type-company-profile node--view-mode-company-profile">
<div class="company-profile-block">
<div class="group-wrapper">
<div class="company-logo">
</div>
<div class="label">
<span class="field field--name-title field--type-string field--label-hidden"> Siemens
</span>
</div>
</div>
</div>
</div>
</div>
<span class="field field--name-title field--type-string field--label-hidden"> Siemens: safe mobility solutions for smart cities
</span>
</div>
</div>
</div>
</div>
</div>
<div class="views-row">
<div data-history-node-id="105222" role="article" about="https://energydigital.com/company/siemens-energy-and-tenable-collaboration-securing-digital-transformation-energy-sector" title="Siemens Energy  &amp; Tenable: collaboration in securing the digital transformation in the energy sector | Energy Digital" description="We examine the partnership between Siemens Energy and Tenable amid the companies’ ongoing digital transformation journeys..." class="node node--type-company-report node--view-mode-other-companies-reports">
<div class="company-report-block">
<a class="company-report-link" href="https://energydigital.com/company/siemens-energy-and-tenable-collaboration-securing-digital-transformation-energy-sector" rel="bookmark">
<div class="main-image">
<div class="field field--name-field-brochure-cover field--type-entity-reference field--label-hidden field__item"> <img width="300" height="428" alt="Siemens Energy  &amp; Tenable: collaboration in securing the digital transformation in the energy sector" loading="lazy" class="lazyload image-style-_-10-crop" data-src="/sites/default/files/styles/7_10_crop/public/405wf62akkzfpyjp100220215410.jpeg?itok=jiqkYx_t" typeof="foaf:Image" />
</div>
</div>
</a>
<div class="group-wrapper">
<div class="company">
<div class="field field--name-field-company field--type-entity-reference field--label-hidden field__item">
<div data-history-node-id="138121" role="article" about="https://energydigital.com/company/siemens-energy" title="Siemens Energy | Energy Digital" class="node node--type-company-profile node--view-mode-company-profile">
<div class="company-profile-block">
<div class="group-wrapper">
<div class="company-logo">
</div>
<div class="label">
<span class="field field--name-title field--type-string field--label-hidden"> Siemens Energy
</span>
</div>
</div>
</div>
</div>
</div>
<span class="field field--name-title field--type-string field--label-hidden"> Siemens Energy &amp; Tenable: collaboration in securing the digital transformation in the energy sector
</span>
</div>
</div>
</div>
</div>
</div>
<div class="views-row">
<div data-history-node-id="105214" role="article" about="https://energydigital.com/company/bkw-group-driving-digital-change-energy-and-technology" title="BKW Group: Driving digital change for energy and technology | Energy Digital" description="Thomas Zinniker, Chief Information Officer at BKW Group, explains how business is thriving through synergies across energy, grid and services..." class="node node--type-company-report node--view-mode-other-companies-reports">
<div class="company-report-block">
<a class="company-report-link" href="https://energydigital.com/company/bkw-group-driving-digital-change-energy-and-technology" rel="bookmark">
<div class="main-image">
<div class="field field--name-field-brochure-cover field--type-entity-reference field--label-hidden field__item"> <img width="300" height="428" alt="BKW Group: Driving digital change for energy and technology" loading="lazy" class="lazyload image-style-_-10-crop" data-src="/sites/default/files/styles/7_10_crop/public/404no22rki03ku1x271120200254.jpeg?itok=GbYWv5PW" typeof="foaf:Image" />
</div>
</div>
</a>
<div class="group-wrapper">
<div class="company">
<div class="field field--name-field-company field--type-entity-reference field--label-hidden field__item">
<div data-history-node-id="138120" role="article" about="https://energydigital.com/company/bkw-group-0" title="BKW Group | Energy Digital" class="node node--type-company-profile node--view-mode-company-profile">
<div class="company-profile-block">
<div class="group-wrapper">
<div class="company-logo">
</div>
<div class="label">
<span class="field field--name-title field--type-string field--label-hidden"> BKW Group
</span>
</div>
</div>
</div>
</div>
</div>
<span class="field field--name-title field--type-string field--label-hidden"> BKW Group: Driving digital change for energy and technology
</span>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="layout layout--onecol" id="onecol-section-videos">
<div class="layout__region layout__region--content">
<div class="views-element-container block block-views block-views-blockvideos-content-videos-homepage videos-block">
<h2>Videos</h2>
<div class="views-element-container"><div class="videos one-full-width-and-three-on-other-row videos-homepage view view-videos-content view-id-videos_content view-display-id-videos_homepage js-view-dom-id-be2d1ac6bbca3318010c502059da338cf0780726723e909d576a8d624dbb08db">
<div class="view-header">
<a href="/videos" class="explore_button">Explore</a><div class="videos 1-full-width-and-3-on-other-row videos-homepage _-full-width-and-3-on-other-row view view-videos-content view-id-videos_content view-display-id-main_video js-view-dom-id-d7dbddd599282ec5d62ff77355b64280ca15e321e7e29c46b0c622e1ead8c26c">
<div class="view-content">
<div class="views-row">
<div data-history-node-id="163557" role="article" about="https://energydigital.com/video/mikko-uusital-ceo-edzcom-0" title="Energy Digital Homepage | Energy Digital" class="node node--type-videos node--view-mode-teaser video-node">
<div class="video-block">
<div class="main-image">
<a class="block-node-link" href="https://energydigital.com/video/mikko-uusital-ceo-edzcom-0"></a>
<div class="field--name-field-media-video">
<img class="image-style-ma lazyloaded" src="https://i.ytimg.com/vi/IF49hap0KQU/maxresdefault.jpg" alt="Youtube img" />
</div>
</div>
<div class="group-wrapper">
<a class="play-button" href="https://energydigital.com/video/mikko-uusital-ceo-edzcom-0">Play</a>
<a class="block-node-link" href="https://energydigital.com/video/mikko-uusital-ceo-edzcom-0"></a>
<div class="node-title">
<h2>
<a href="https://energydigital.com/video/mikko-uusital-ceo-edzcom-0" rel="bookmark"><span class="field field--name-title field--type-string field--label-hidden"> Mikko Uusital, CEO of Edzcom
</span>
</a>
</h2>
</div>
<div class="category-and-time">
<div class="category">
<div class="field field--name-field-category field--type-entity-reference field--label-hidden field__item"><a href="https://energydigital.com/topics/technology-and-ai" hreflang="en">Technology &amp; AI</a></div>
</div>
</div>
<div class="read-now">
<a class="read-now-button" href="https://energydigital.com/video/mikko-uusital-ceo-edzcom-0" rel="bookmark">Watch now</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="view-content">
<div class="views-row">
<div data-history-node-id="163553" role="article" about="https://energydigital.com/video/meet-edzcom-0" title="Energy Digital Homepage | Energy Digital" class="node node--type-videos node--view-mode-teaser video-node">
<div class="video-block">
<div class="main-image">
<a class="block-node-link" href="https://energydigital.com/video/meet-edzcom-0"></a>
<div class="field--name-field-media-video">
<img class="image-style-ma lazyloaded" src="https://i.ytimg.com/vi/bxUiJhnRQOc/hqdefault.jpg" alt="Youtube img" />
</div>
</div>
<div class="group-wrapper">
<a class="play-button" href="https://energydigital.com/video/meet-edzcom-0">Play</a>
<a class="block-node-link" href="https://energydigital.com/video/meet-edzcom-0"></a>
<div class="node-title">
<h2>
<a href="https://energydigital.com/video/meet-edzcom-0" rel="bookmark"><span class="field field--name-title field--type-string field--label-hidden"> Meet Edzcom
</span>
</a>
</h2>
</div>
<div class="category-and-time">
<div class="category">
<div class="field field--name-field-category field--type-entity-reference field--label-hidden field__item"><a href="https://energydigital.com/topics/technology-and-ai" hreflang="en">Technology &amp; AI</a></div>
</div>
</div>
<div class="read-now">
<a class="read-now-button" href="https://energydigital.com/video/meet-edzcom-0" rel="bookmark">Watch now</a>
</div>
</div>
</div>
</div>
</div>
<div class="views-row">
<div data-history-node-id="161514" role="article" about="https://energydigital.com/video/siemens-driving-future-mobility" title="Energy Digital Homepage | Energy Digital" class="node node--type-videos node--view-mode-teaser video-node">
<div class="video-block">
<div class="main-image">
<a class="block-node-link" href="https://energydigital.com/video/siemens-driving-future-mobility"></a>
<div class="field--name-field-media-video">
<img class="image-style-ma lazyloaded" src="https://i.ytimg.com/vi/LXG9zJCUjWw/maxresdefault.jpg" alt="Youtube img" />
</div>
</div>
<div class="group-wrapper">
<a class="play-button" href="https://energydigital.com/video/siemens-driving-future-mobility">Play</a>
<a class="block-node-link" href="https://energydigital.com/video/siemens-driving-future-mobility"></a>
<div class="node-title">
<h2>
<a href="https://energydigital.com/video/siemens-driving-future-mobility" rel="bookmark"><span class="field field--name-title field--type-string field--label-hidden"> Siemens – Driving the future of mobility
</span>
</a>
</h2>
</div>
<div class="category-and-time">
<div class="category">

<div class="field field--name-field-category field--type-entity-reference field--label-hidden field__item"><a href="https://energydigital.com/topics/sustainability-3" hreflang="en">Sustainability</a></div>
</div>
</div>
<div class="read-now">
<a class="read-now-button" href="https://energydigital.com/video/siemens-driving-future-mobility" rel="bookmark">Watch now</a>
</div>
</div>
</div>
</div>
</div>
<div class="views-row">
<div data-history-node-id="105745" role="article" about="https://energydigital.com/video/new-chapter-siemens" title="Energy Digital Homepage | Energy Digital" class="node node--type-videos node--view-mode-teaser video-node">
<div class="video-block">
<div class="main-image">
<a class="block-node-link" href="https://energydigital.com/video/new-chapter-siemens"></a>
<div class="field--name-field-media-video">
<img class="image-style-ma lazyloaded" src="https://i.ytimg.com/vi/14G0ZC0bEVo/maxresdefault.jpg" alt="Youtube img" />
</div>
</div>
<div class="group-wrapper">
<a class="play-button" href="https://energydigital.com/video/new-chapter-siemens">Play</a>
<a class="block-node-link" href="https://energydigital.com/video/new-chapter-siemens"></a>
<div class="node-title">
<h2>
<a href="https://energydigital.com/video/new-chapter-siemens" rel="bookmark"><span class="field field--name-title field--type-string field--label-hidden"> A new chapter for Siemens
</span>
</a>
</h2>
</div>
<div class="category-and-time">
<div class="category">
<div class="field field--name-field-category field--type-entity-reference field--label-hidden field__item"><a href="https://energydigital.com/topics/smart-energy" hreflang="en">Smart Energy</a></div>
</div>
</div>
<div class="read-now">
<a class="read-now-button" href="https://energydigital.com/video/new-chapter-siemens" rel="bookmark">Watch now</a>
</div>
</div>
</div>
</div>
</div>
<div class="views-row">
<div data-history-node-id="105744" role="article" about="https://energydigital.com/video/we-are-energy-digital" title="Energy Digital Homepage | Energy Digital" class="node node--type-videos node--view-mode-teaser video-node">
<div class="video-block">
<div class="main-image">
<a class="block-node-link" href="https://energydigital.com/video/we-are-energy-digital"></a>
<div class="field--name-field-media-video">
<img class="image-style-ma lazyloaded" src="https://i.ytimg.com/vi/-HQABSwly-E/maxresdefault.jpg" alt="Youtube img" />
</div>
</div>
<div class="group-wrapper">
<a class="play-button" href="https://energydigital.com/video/we-are-energy-digital">Play</a>
<a class="block-node-link" href="https://energydigital.com/video/we-are-energy-digital"></a>
<div class="node-title">
<h2>
<a href="https://energydigital.com/video/we-are-energy-digital" rel="bookmark"><span class="field field--name-title field--type-string field--label-hidden"> We are Energy Digital
</span>
</a>
</h2>
</div>
<div class="category-and-time">
<div class="category">
<div class="field field--name-field-category field--type-entity-reference field--label-hidden field__item"><a href="https://energydigital.com/topics/smart-energy" hreflang="en">Smart Energy</a></div>
</div>
</div>
<div class="read-now">
<a class="read-now-button" href="https://energydigital.com/video/we-are-energy-digital" rel="bookmark">Watch now</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<a id="webform-submission-energy-digital-sub-node-3827-form-ajax-content" tabindex="-1" aria-hidden="true"></a><div id="webform-submission-energy-digital-sub-node-3827-form-ajax" class="webform-ajax-form-wrapper" data-effect="fade" data-progress-type="fullscreen"><div class="exclusive-content-form">
<form class="webform-submission-form webform-submission-add-form webform-submission-energy-digital-sub-form webform-submission-energy-digital-sub-add-form webform-submission-energy-digital-sub-node-3827-form webform-submission-energy-digital-sub-node-3827-add-form js-webform-details-toggle webform-details-toggle" data-drupal-selector="webform-submission-energy-digital-sub-node-3827-add-form" action="/company/mpower" method="post" id="webform-submission-energy-digital-sub-node-3827-add-form" accept-charset="UTF-8">
<div class="form-title">
To Continue Reading
</div>
<div class="form-description">
Subscribe to our newsletter to get unlimited access
</div>
<div class="form">
<div class="js-form-item form-item js-form-type-textfield form-type-textfield js-form-item-first-name form-item-first-name">
<label for="edit-first-name" class="js-form-required form-required">First name</label>
<input data-drupal-selector="edit-first-name" type="text" id="edit-first-name" name="first_name" value="" size="60" maxlength="255" placeholder="First name" class="form-text required form-control" required="required" aria-required="true" />
</div>
<div class="js-form-item form-item js-form-type-textfield form-type-textfield js-form-item-last-name form-item-last-name">
<label for="edit-last-name" class="js-form-required form-required">Last name</label>
<input data-drupal-selector="edit-last-name" type="text" id="edit-last-name" name="last_name" value="" size="60" maxlength="255" placeholder="Last name" class="form-text required form-control" required="required" aria-required="true" />
</div>
<div class="js-form-item form-item js-form-type-email form-type-email js-form-item-work-email-address form-item-work-email-address">
<label for="edit-work-email-address" class="js-form-required form-required">Work email address</label>
<input data-webform-required-error="Add email address" data-drupal-selector="edit-work-email-address" type="email" id="edit-work-email-address" name="work_email_address" value="" size="60" maxlength="254" placeholder="Work email address" class="form-email required form-control" required="required" aria-required="true" />
</div>
<div class="js-form-item form-item js-form-type-textfield form-type-textfield js-form-item-job-title form-item-job-title">
<label for="edit-job-title" class="js-form-required form-required">Job title</label>
<input data-drupal-selector="edit-job-title" type="text" id="edit-job-title" name="job_title" value="" size="60" maxlength="255" placeholder="Job title" class="form-text required form-control" required="required" aria-required="true" />
</div>
<div data-drupal-selector="edit-actions" class="form-actions webform-actions js-form-wrapper form-wrapper" id="edit-actions">
<input class="webform-button--submit button button--primary js-form-submit form-submit btn btn-primary" data-drupal-selector="edit-actions-submit" data-disable-refocus="true" type="submit" id="edit-actions-submit" name="op" value="Join our community" />
</div>
<input autocomplete="off" data-drupal-selector="form-jqejdb7h8hkdoktklcx2bd8qxbqksldjiqo4bqb7li" type="hidden" name="form_build_id" value="form--JQEJdB7h8hKDoKTklcx2Bd8QxbQksLdjIQo4bQB7LI" class="form-control" />
<input data-drupal-selector="edit-webform-submission-energy-digital-sub-node-3827-add-form" type="hidden" name="form_id" value="webform_submission_energy_digital_sub_node_3827_add_form" class="form-control" />
</div>
<div class="form-footer">
</div>
</form>
</div>
</div>
</div>
</div>
</div>
<div id="block-gamwpopupblock" class="block block-bizclik-site block-gamwpopupblock">
<div class="advertisement energy_digital" id="energy_digital">
<div class="banner-wrapper">
<div id="gamw_e80ce766-c4e6-4a1c-899e-95e534b0e69e" data-uuid="e80ce766-c4e6-4a1c-899e-95e534b0e69e" data-ad-unit="erg_1920x1080"></div>
</div>
<div class="group-wrapper">
<div class="group-left">
<span>Powered by</span>
<img src="https://energydigital.com/sites/default/files/styles/ma/public/brand-images/Energy-White.png?itok=rmbW7Iw2" alt="logo" />
</div>
<div class="group-right">
<a class="btn-link" href="https://energydigital.com/company/mpower">Join our community</a>
</div>
</div>
<div class="btn-close">Close</div>
</div>
</div>
</div>
</main>
<footer role="contentinfo" class="footer">
<div class="footer-region">
<div class="left-footer-region">
<div class="region region-left-footer-region">
<div id="block-footer-logo" class="footer-site-branding block block-system block-system-branding-block">
<div class="site-brand">
<a href="/" title="Home" rel="home" class="site-logo">
<img src="https://energydigital.com/sites/default/files/styles/ma/public/brand-images/Energy-White.png?itok=rmbW7Iw2" alt="Home" />
</a>
</div>
</div>
<nav role="navigation" aria-labelledby="block-social-2-menu" id="block-social-2" class="footer-socials footer-socials-mobile socials-block block block-menu navigation menu--social">
<h5 class="visually-hidden" id="block-social-2-menu">Social</h5>
<ul class="menu">
<li class="menu-item">
<a href="https://www.linkedin.com/company/energy-digital-magazine" target="_blank" rel="noopener">LinkedIN</a>
</li>
<li class="menu-item">
<a href="https://twitter.com/Energy_Digital_" target="_blank" rel="noopener">Twitter</a>
</li>
<li class="menu-item">
<a href="https://www.facebook.com/energydigitalmag/" target="_blank" rel="noopener">Facebook</a>
</li>
<li class="menu-item">
<a href="https://www.instagram.com/energydigitalmag/" target="_blank" rel="noopener">Instagram</a>
</li>
<li class="menu-item">
<a href="https://www.youtube.com/channel/UCs4CepFq0mjqtede4rx0xdA" target="_blank" rel="noopener">Youtube</a>
</li>
<li class="menu-item">
<a href="https://medium.com/energy-digital" target="_blank" rel="noopener">Meduim</a>
</li>
</ul>
</nav>
<nav role="navigation" aria-labelledby="block-sitefootermenu-menu" id="block-sitefootermenu" class="footer-main-menu footer-menu block block-menu navigation menu--site-footer-menu">
<h5 class="visually-hidden" id="block-sitefootermenu-menu">Site footer menu</h5>
<ul class="menu">
<li class="menu-item">
<a href="/magazine" data-drupal-link-system-path="magazine">Magazine</a>
</li>
<li class="menu-item">
<a href="/company_listings" data-drupal-link-system-path="company_listings">Companies</a>
</li>
<li class="menu-item">
<a href="/videos" data-drupal-link-system-path="videos">Videos</a>
</li>
<li class="menu-item">
<a href="/events" data-drupal-link-system-path="events">Events</a>
</li>
<li class="menu-item">
<a href="/top_10" data-drupal-link-system-path="top_10">Lists</a>
</li>
</ul>
</nav>
<nav role="navigation" aria-labelledby="block-sitesecondmenufooter-menu" id="block-sitesecondmenufooter" class="footer-second-menu footer-menu block block-menu navigation menu--site-second-menu-footer">
<h5 class="visually-hidden" id="block-sitesecondmenufooter-menu">Site second menu footer</h5>
<ul class="menu">
<li class="menu-item">
<a href="/about_us" data-drupal-link-system-path="about_us">About us</a>
 </li>
<li class="menu-item">
<a href="/contact_us" data-drupal-link-system-path="contact_us">Contact us</a>
</li>
<li class="menu-item">
<a href="/advertise" data-drupal-link-system-path="advertise">Advertise</a>
</li>
<li class="menu-item">
<a href="/press-release" data-drupal-link-system-path="press-release">Press Releases</a>
</li>
<li class="menu-item">
<a href="/pr_newswire" data-drupal-link-system-path="pr_newswire">PR Newswire</a>
</li>
</ul>
</nav>
<div id="block-poweredby" class="copyright-powered-by block block-block-content block-block-content66344e09-fa52-41cf-9cfb-6d5aa40df2e7">
<div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><div class="powered-by">
<div class="powered-by-title">
<p>Powered by</p>
</div>
<div class="logo-advertise">
<div class="powered-by-logo"><a href="https://www.bizclikmedia.com/contact" rel="noopener" target="_blank"><img alt="BizClik Media" src="/themes/custom/bizclik_sites/bizclik-logo.svg" /></a></div>
<div class="powered-by-advertise"><a href="https://www.bizclikmedia.com/contact" rel="noopener" target="_blank">Advertise with BizClik</a></div>
</div>
<div class="policy">© 2021&nbsp;BizClik Media Limited, All Rights Reserved. <a href="/termsOfUse">User Agreement</a> and <a href="/privacy_policy">Privacy Policy</a></div>
</div>
</div>
</div>
</div>
</div>
<div class="right-footer-region">
<div class="region region-right-footer-region">
<nav role="navigation" aria-labelledby="block-footer-social-menu" id="block-footer-social" class="footer-socials footer-socials-desktop socials-block block block-menu navigation menu--social">
<h5 class="visually-hidden" id="block-footer-social-menu">Social</h5>
<ul class="menu">
<li class="menu-item">
<a href="https://www.linkedin.com/company/energy-digital-magazine" target="_blank" rel="noopener">LinkedIN</a>
</li>
<li class="menu-item">
<a href="https://twitter.com/Energy_Digital_" target="_blank" rel="noopener">Twitter</a>
</li>
<li class="menu-item">
<a href="https://www.facebook.com/energydigitalmag/" target="_blank" rel="noopener">Facebook</a>
</li>
<li class="menu-item">
<a href="https://www.instagram.com/energydigitalmag/" target="_blank" rel="noopener">Instagram</a>
</li>
<li class="menu-item">
<a href="https://www.youtube.com/channel/UCs4CepFq0mjqtede4rx0xdA" target="_blank" rel="noopener">Youtube</a>
</li>
<li class="menu-item">
<a href="https://medium.com/energy-digital" target="_blank" rel="noopener">Meduim</a>
</li>
</ul>
</nav>
<div id="block-footersiteinfoandlatestmagazine" class="footer-site-info block block-bizclik-site block-footersiteinfo">
<div class="latest-magazine">
<div class="views-element-container"><div class="latest-issue view view-footer-latest-issue-out-now view-id-footer_latest_issue_out_now view-display-id-latest_issue js-view-dom-id-9b31e16e82be8ea348286219d1c67bb6aae5909a9b202fc6f1fd1f2839dc600f">
<div class="view-content">
<div class="views-row"><div class="views-field views-field-nothing"><span class="field-content"><div class="magazines-block">
<div class="magazines-cover">
<a class="magazine-link-button" href="/magazine">
<article class="media media--type-image media--view-mode-_-10-crop">
<div class="field field--name-field-media-image field--type-image field--label-hidden field__item"> <img width="300" height="424" alt="" loading="lazy" class="lazyload image-style-_-10-crop" data-src="/sites/default/files/styles/7_10_crop/public/image/01-Enery-Cover-May2021_0.jpg?itok=pwtm1rKd" typeof="Image" />
</div>
</article>
</a>
</div>
<div class="magazine-link">
<a class="magazine-link-button" href="/magazine" rel="bookmark">
Read now
</a>
</div>
</div></span></div></div>
</div>
</div>
</div>
</div>
<div class="site-info">
<div class="site-name">
Energy Digital
</div>
<div class="site-description">
Energy Digital Magazine is the ‘Digital Community’ for the oil &amp; gas, utilities and renewable energy industry. Energy Digital Magazine covers Energy 4.0, Global Energy investments, innovation, automation &amp; AI, smart technologies and sustainability - connecting the world’s largest community of renewable energy executives. Energy Digital Magazine focuses on energy news, key energy interviews, energy videos, the &#039;Energy Podcast&#039; series along with an ever-expanding range of focused energy white papers and webinars.
</div>
</div>
</div>
</div>
</div>
</div>
</footer>
</div>
</div>
<!--[if lte IE 8]>
<script src="/sites/default/files/js/js_VtafjXmRvoUgAzqzYTA3Wrjkx9wcWhjP0G4ZnnqRamA.js"></script>
<![endif]-->
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/3827","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"ajaxPageState":{"libraries":"addtoany\/addtoany,bizclik_site\/bizclik_site,bizclik_sites\/global-styling,bootstrap4\/bootstrap4-js-latest,bootstrap4\/global-styling,classy\/base,classy\/messages,classy\/node,core\/html5shiv,core\/normalize,gamw\/ad,genpass\/genpass,google_analytics\/google_analytics,layout_builder\/twocol_section,layout_discovery\/onecol,lazy\/lazy,statistics\/drupal.statistics,system\/base,views\/views.module,webform\/webform.ajax,webform\/webform.element.details.save,webform\/webform.element.details.toggle,webform\/webform.element.message,webform\/webform.form,webform\/webform.theme.classy","theme":"bizclik_sites","theme_token":null},"ajaxTrustedUrl":{"form_action_p_pvdeGsVG5zNF_XLGPTvYSKCf43t8qZYSwcfZl2uzM":true,"https:\/\/energydigital.com\/company\/mpower?ajax_form=1":true,"\/search":true},"google_analytics":{"account":"UA-88969255-1","trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip","trackColorbox":1},"lazy":{"lazysizes":{"lazyClass":"lazyload","loadedClass":"lazyloaded","loadingClass":"lazyloading","preloadClass":"lazypreload","errorClass":"lazyerror","autosizesClass":"lazyautosizes","srcAttr":"data-src","srcsetAttr":"data-srcset","sizesAttr":"data-sizes","minSize":40,"customMedia":[],"init":true,"expFactor":1.5,"hFac":0.8,"loadMode":2,"loadHidden":true,"ricTimeout":0,"throttleDelay":125,"plugins":[]},"placeholderSrc":"","preferNative":false},"statistics":{"data":{"nid":"3827"},"url":"\/core\/modules\/statistics\/statistics.php"},"ajax":{"edit-actions-submit":{"callback":"::submitAjaxForm","event":"click","effect":"fade","speed":500,"progress":{"type":"fullscreen","message":""},"disable-refocus":true,"url":"https:\/\/energydigital.com\/company\/mpower?ajax_form=1","dialogType":"ajax","submit":{"_triggering_element_name":"op","_triggering_element_value":"Join our community"}}},"field_group":{"fieldset":{"mode":"company_report_side_bar","context":"view","settings":{"id":"company-social","classes":"company-social","description":""}}},"gamw":{"blocks":{"ergcompany_300x250":{"372194e9-7967-42c9-8a86-a2f0c7514436":{"uuid":"372194e9-7967-42c9-8a86-a2f0c7514436","ad_unit":"ergcompany_300x250","sizes":[{"300x250":[300,250]},{"300x250":[300,250]}],"dev_mode":0,"collapsed":0,"targeting_attributes":{"company":"3827","site":"BizClik Media"},"gamw_id":"80843160"}},"ergcompany_300x600":{"c8e09152-881b-4d17-9997-5ccd850a5688":{"uuid":"c8e09152-881b-4d17-9997-5ccd850a5688","ad_unit":"ergcompany_300x600","sizes":[{"300x600":[300,600]},{"300x600":[300,600]}],"dev_mode":0,"collapsed":0,"targeting_attributes":{"company":"3827","site":"BizClik Media"},"gamw_id":"80843160"}},"ergcompany_970x250":{"69331ee1-3028-4f25-89e7-683c478f1224":{"uuid":"69331ee1-3028-4f25-89e7-683c478f1224","ad_unit":"ergcompany_970x250","sizes":{"0":{"320x50":[320,50]},"1":{"320x50":[320,50]},"992":{"970x250":[970,250]}},"dev_mode":0,"collapsed":0,"targeting_attributes":{"company":"3827","site":"BizClik Media"},"gamw_id":"80843160"}},"erg_1920x1080":{"e80ce766-c4e6-4a1c-899e-95e534b0e69e":{"uuid":"e80ce766-c4e6-4a1c-899e-95e534b0e69e","ad_unit":"erg_1920x1080","sizes":{"400":{"382x432":[382,432]},"768":{"768x432":[768,432]},"992":{"768x432":[768,432]},"1024":{"768x432":[768,432]},"1440":{"1024x576":[1024,576]},"1600":{"1440x810":[1440,810]},"1920":{"1600x900":[1600,900]},"1970":{"1920x1080":[1920,1080]},"2560":{"1920x1080":[1920,1080]}},"dev_mode":0,"collapsed":0,"targeting_attributes":{"site":"BizClik Media"},"gamw_id":"80843160"}}}},"user":{"uid":0,"permissionsHash":"bc53c7c8b84d9537ceef47c7414dcb13766c886bbe358d44c566768bf9991a0a"}}</script>
<script src="/sites/default/files/js/js_BZNsmom6hD5MdsQPs604zvJimS4dDNOmmLX5mEsDljc.js"></script>
<script src="https://static.addtoany.com/menu/page.js" async></script>
<script src="/sites/default/files/js/js_btpofUALEHTe6IoJA38qLVcF5n_h_5RHb7qBuz4NkLA.js"></script>
<script type="text/javascript">(function(){window['__CF$cv$params']={r:'65bb30d4aa56e724',m:'e5213d860bdc4ace4fc6569bce2b1fcab56fb713-1623082649-1800-AdxUXdUi9YjmhkGWMzc3BH1cJL0bQiSGWi38ef7kquuFAgWpQL1e9vm5Jh+J80vqZPind3sWVnYPeoi6+hgx4a1/IZ6ifE2toA/5FxbLp4w6qZAjFXDCyXClUaI+SYHJWQ==',s:[0x9a979bddda,0x599897711e],}})();</script></body>
</html>
